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Maobile OS

BlackBerry 1.0 BlackBerry 7.0

January 1999 May 2011 Research In Motion

BlackBerry

Symbian 1 Symbian Belle Nokia
October 2008 August 2011 (Accenture)

Symbian




Some history

* Oct/2003: Born of Android Inc.

* Aug/2005: Google acquire Android Inc.

* Nov/2007: OHA (Open Handset Alliance)
* TelecomlItalia, Vodafone
* Acer, Asus, Dell, Samsung, HTC, Toshiba etc.
* Android Open Source Project (AOSP)

* Sep/2008: release of Android 1.0

* May/2011: release of Android 4.0



What is ANDROID?

* Operating System for mobile devices
* Kernel based on the Linux kernel
* Middleware, libraries and APIs written in C

* Application framework includes
Java-compatible libraries

* Dalvik Virtual Machine to run Dalvik dex-code



Why ANDROID?

—

* A simple and powerful SDK
* No licensing, distribution, or development fees

* Development over many platform
* Linux, Mac OS, Windows

* Excellent documentation
* Large developer community

* No constraints on new Apps.



Why ANDROID?

—

Seiin: Repubblica > Tecnologia > Privacy, allarme smartphone-spla un ..

LA SCOPERTA +1 ¥ Tweel 3 B Consigiia

Privacy, allarme smartphone-spia
un software registra le nostre vite

Dopo il caso che ha colpito | melafonini, scoperto anche sui sistemi Android un software capace di
registrare le attivita e la posizione degli utenti. E c'e gia chi accusa anche Nokia e Blackberry. Allarme

privacy anche in due grandi centri commerciall Usa

di LAURA BONASERA
ANCORA UNAVOLTA, gh smartphone nschiano di essere
una minaccia alla privacy. In tasca o in borsa,
accompagnano milioni di persone in tutto 1| mondo ogni
giorno. E non importa se, a maneggiarlo, non sono solo

Android. Il sistema di Google, per essere chiari




Why ANDROID?

—

APPLE ti

Anche su Mac tentativi di virus
Tsunami ci prova con la mela

Il centro ricerche di Eset individua una minaccia nascosta in un file pdf in grado di infettare | sistemi
Macintosh. "Anche quest utenti hanno bisogno di protezione”, dice I'azienda. E la distrazione pud causare
danni ser|

¥ Tweet 20

ANCHE per gli utenti Apple e tempo di pensare alla
sicurezza. Il centro ricerche di Eset, i produttor
dell'antivirus Nod32, ha appena isolato una nuova
minaccia originariamente creata per Linux, chiamata
Linux/Tsunami, ora rilevata anche sui sistemi Mac, e
quindi identificata come OsX/Tsunami.

Per ora della minaccia virale e stata solo scoperta
I'esistenza e non risulta diffusione esterna. Ma ¢
abbastanza per invitare anche gli utenti Mac a proteggere
| propri sistemi.
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ANDROQOID Tools > SDK

— ——— — e ——— - ——— - ——— -

* To simplify development Google provides the Android
Development Tools (ADT) for Eclipse.

* The applications are written in Java.

* Android applications are packed into an .apk (Android
Package) file by the program aapt (Android Asset Packaging
Tool)

* The Android NDK is a companion tool to the Android SDK that
lets you build portions of your apps in native code (C/C++).



ANDROID Tools > Dalvnik JVM

— ——— — e ——— - ——— ——— -

¢ Android uses a special virtual machine, the Dalvik Virtual
Machine.

* Dalvik uses special bytecode. Therefore you cannot run
standard Java bytecode on Android.

¢ Android provides a tool dx which allows to convert Java Class
files into dex (Dalvik Executable) files.

* The ADT performs automatically the conversion from class to
dex files and creates the apk during deployment.



ANDROID Tools > Emulator

- Implementation of the Android virtual machine
- Test and debug your android applications.
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ANDROID Tools > Andr0|d Vlrtual DeV|ce Manager -w ‘;&cf ‘1”
\

- Create and monitor the Virtual Machines

Android SDK and AVD Manager

¥

: List of existing Android Virtual Devices located at /home/elton/.android/avd
Installed packages AVD Name Target Name Platform API Level New...
Available packages v And22 Android 2.2 2.2 8
v my_app Android 2.3 2.3

g
v Google Google APIs (Google Inc.) 2.3 9
v googleApi Google APIs (Google Inc.) 2.3 9

Refresh

~ Avalid Android Virtual Device. A repairable Android Virtual Device.
X An Android Virtual Device that fFailed to load. Click 'Details' to see the error.
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ANDROID Tools > Dalvik Debug Monitoring Service v

: £

—

- Monitor and Control the Dalvik virtual machines
- Logcat (see logged msgs)

File Edit Refactor Source Run Navigate Search Project Window Help

By O Qv | ™ - £ |Spbms &'. ”

& Devices 2 = B||%, Threads @ Heap | @ Allocation Tracker ' File Explorer &3 ¥ = 0O||B) Emulator Control 2 =50

# B & % 2 @ M T ||Name Size Date Time Permissions Info Telephony Status

Fe—— | i> & data 2011-10-19  14:23 drwxrwx-x Voice: | home * | Speed: | Full
v @ ) X 1|[» & mnt 2011-11-23 16:51 drwxrwxr-x =
ersn::ta:;r_;fj:ess ?;Eme b Bt navensma 2] dnre Data: | home s | Latency: | Nong|

jp.co.omronsoft.openwnn 119 Telephony Actions

com.android.phone 124 Incoming number:

com.android.launcher 126

com.android.settings 129

android.process.acore 163

com.android.alarmclock 172

com.android.music 185

com.android.quicksearchbox 195

P — iann

LogcCat &2 Bl console VO OO + B v =8

Log

Filter:



Manage the state of an emulator or device
Run shell commands on a device

Manage port forwarding on an emulator or device
- Copy files to/from an emulator or device

root@demnoja: /usr/local/sharesw/android-sdk-1linux 86/platform-tools# ./adb

Android Debug Bridge wersion 1.

directs
returns
directs
returns

number> directs

command to the only connected USB device

an error 1f more than one USB device 15 pres
command to the only running emulator.

an error if more than one emulator is running.
command to the USB device or emulator with

ks

4]
[{i]

the given serial number. Overrides ANDROID SERIAL
environment variable.

imple product name like 'sooner', or
relative/absolute path to a product

directory like 'out/target/product/sooner’.

f -p 1s not specified, the ANDROID PRODUCT OUT
environment wvariable is used, which must

be an absolute path.

all connected devices

-p <product name or path>

0 pou

=

devices

connect <host>[:<port>] connect

to a device via TCP/IP

5555 is used by default if no port number is specified.
disconnect from a TCP/IP device.

disconnect [<host>[:<port>]]

5555 18 used by default 1f no port number i1s specified.
Using this command with no additional arguments
will disconnect from all connected TCP/IP devices.



Component > Activity

— ——— = — — —— - ——— - ——— o

« Is a single application entity that is used to perform
actions.

* An application may have many separate activities,
but the user interacts with them one at a time.

* Is not required to have a user interface.

* Are divided in three categories:

- Foreground Activity: suspended when invisible
- Background Service: Little interaction
- Intermittent Activity



Component > Activity

o ™ g N % [ N7 Activiby. N 7 = W s e
Activity. TRIY: Activity. | | . onSave — .'!'.Etl'-.lll'_'.-'.\]
onCreate onREstoe o™ o ochart Activity. [\ instanceState [ ™| Activity. onDestroy|

\InstanceState, onResume -~ | onPause

M WL ooy T A
| Activity. |
| onHestart |
L% P

- =

Active | fetime
Visible Lifetime

Full Litatime

public class Activity extends ApplicationContext {
protected void onCreate(Bundle savedInstanceState);

protected void onStart();
protected void onRestart();
protected void onResume();
protected void onPause();
protected void onStop();

protected void onDestroy();




Component > View

——— ————

« User interface of an Activity.

* Is built with:
- Widget classes:

- Layout: linear, grid, tab, list, etc.
- TextView, EditText, Button, Form, TimePicker, etc.
- AutoCompletition, MapView, WebView etc.

- Menu



Component > View > Layout

Layout: linear, grid, tab, list, etc.
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Component > View > Widgets

TextView, EditText, Button, Form, TimePicker, etc.

Plesse seledt o planets

Hello DavePFicher

@ Mon, 04 August, 2008




Component > View > Menu

Il"

Second Menu Item

First Menu Item

Third Menu Item Fourth Menu Item

Fifth Menu Item




Component > View > Intent

Are asynchronous messages which allow the
application to request functionality from other services
or activities.

An application can call directly a service or activity
(explicit intent) or ask the Android system for
registered services and applications for an intent
(implicit intents).



Component > View > Service

Perform background tasks without providing an UI.

They can notify the user via the notification framework
in Android.

- Service class

> public class MyService extends Service
> public void onStart() {...}

> Control

> startService()
> stopService()

> Communication
> Bind service with activity: use public method and properties
> Intent



Component > View > ContentProvider

Se—m — — — e —— = ——— ——m—

Provides data to applications, via a content provider your
application can share data with other applications.
Android contains a SQLite DB which can serve as data
provider



Resources

¥ 1= Emergency

A : project source and business [-—_—_

logic; > &8 gen [Generated Java Fil
= Androig 2.2

3 . auto generated file » mi Referenced Libraries

D : images and external sty

sources. Can be specific for > & drawable

* = drawable-hdpi

different image quality;

> = drawable-ldpi

> (= drawable-mdpi

- : XML layout source code; [,

* = meny
7 : XML menu source code; St

< AndroidManifest.xml
> : XML range value for new |t

predeﬁned typeS, proguard.cfg




Resources (2)

— ——— — — - —— - ———

r : contains the final .apk file and other compiled
resources.

y : contains native code sources developed using the
Android NDK

1 : this is empty, can be used to store raw asset
files.

A . store the animation files.

% : For XML files that describe colors.

% : for miscellaneous XML files that configure

application components;
2 : contains private libraries.



Resources (3)

— ——— - — — - —— - — — -

A : The control file that describes
the nature of the application and each of its components.
3 . contains project settings, such as

the build target.

2 . customizable computer-specific

properties for the build system.

- : customizable properties for the build
system.
; : the Ant build file for your project. This is

only applicable for projects that you build with Ant.



Component > Manifest

<?xml version="1.8" encuding—“urf 8"7>
-<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="em. home"
android:versionCode="1"
android:versionName="1.8">

1ission android:name="android. penmissian INTERNET" /=
es-f n android: name-”androld perm1551on RUN INSTRUMENTATION" /=
- <yses-permission android:name="android.permission.ACCESS FINE LOCATION"/>
s-permission android:name="android.permission.READ PHONE STATE" />
ion android:name="android.permission.ACCESS MOCK LOCATION" />
ion android:name="android.permission. WRITE EXTERNAL STORAGE" /

<application android:icon="@drawable/icon" android:label="@string/app name" android:debuggable="true"
kndroid:name="JEmergencyApp">

<service android:name="jade.android.MicroRuntimeService" /=
<activity android:label="@string/app name" android:screenOrientation="portrait"
andruid theme="@android:style/Theme.NoTitleBar" android:name="HomeActivity">
itent-filter>
<action android:name="android.intent.action.MAIN" />
=category android:name="android. intent.category.LAUNCHER" /=
filter>

<act y android:name="DeviceActivity" android:screenOrientation="portrait"=</activity=
<gctiv _r android:name="HealthActivity" android:screenOrientation="portrait"></activity=
cactivity android:name="PersonalActivity" android:screenOrientation="portrait“></activity=
<j.-1~*r~ android:name="5SplashScreenActivity" androld:launchMode="singleInstance"
and:uld configChanges="keyboard|orientation" android:screenOrientation="portrait"=</activity>




e project source code
" @ em:home Activity

b [J] DeviceActivity.java

> [J] HealthActivity.java SeI‘ViCG

b |J] HomeActivity.java >

> 1] JEmergencyApp.java ContentProvider
iJ| PersonalActivity.java
U] SpinnerAdapter.java package em.home;
[7] splashScreenActivity.java

> em.jade import java.io.File;

* B em.key

» 1 em.ontology ] . . .
public class DeviceActivity extends Activity{

or debugging purpose.

priuate final Logger mylLogger = Logger.getMyLogger(this.getClass().getName());

] :-_5r.-'| gel r1le -i_:4 cglvare

private final static string FILE PATH = "ecgtracereceived.jpg";

EditText et ecqg frequency;
EditText et ecg cathegory;
EditText et oximeter frequency;
EditText et oximeter persentage;
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R.java is a generated class which contains references to

resources of the res folder in the project. These resources

are defined in the res directory and can be values,

menus, layouts, icons or pictures or animations. For

example a resource can be an image or an XML file
Wthh deﬁnes Strings, /' public class HealthActivity extends Activity{

en\R.java
;gi__, = J___. ® som w v & : ; . e e s ¢ XYl \ﬂii:Pi

private CheckBox burnBox;
private CheckBox headBox;
private CheckBox spinalBox;
private CheckBox facialBox;
private CheckBox multiBox;

nrivate TableLavout container

¥ it em.home ¥ = layout

¥ dialog.xml

b [J] R.java S
{ alll.AITh

x| splashscreen.xml
¥ tab1.xml

X| tab2.xmil

\ ¥ tab3.xml




res\drawable

Bl gam
v = I ':IEI

¥ = drawable

X t tab .heatth-:r:.rrt . .
g B xml: instruction file about the

x| insets.xmil condition;
&y symbol.png
| drawable-hdpi . o
5 :m E: .png/.jpg/...: image file;
E, ICoN.pNg
¥ = drawable-ldpi

5 I: X, icon. png

» = drawable-mdpi



res\layout

————

¥ = layout
K| dialog.xml
| main.xml
splashscreen.xml
tab1.xmil
tab2.xmil
tab3.xml

eml version="1.0" encoding="utf-8"7>

- layout principale --=

<ScrollView xmlns:android="http://schemas.ar
android: layout width="fill parent"
android: layout height="wrap content"=

(5) SeekBar

(S Spinner

(M TextView

(T) TimePicker

(T ToggleButton
{T) TwoLineListitem
& videoView

@ ZoomButton

(@ ZoomControls
—= Layouts =

(a) AbsoluteLayout
(D] DialerFilter

(E] ExpandableListView

(F] FrameLayout
@ GridView
[H) HorizontalScrollView

layout secondario per la organizzazione a tabella dei text
bleLayout android:layout width="fill parent"
android:layout height="wrap content"
android:id="@+id/top table"s
<TableRow android:layout width="wrap content"
android:layout height="wrap content" android:id="@+id/firstRow">

- View android:text="@string/name® android:id="@+id/twname" /=

Text android:layout weight="1" android:id="@+id/name" /=




res\menu

| send (Iltem)
conneck {Item)

settings (Iltem)

receive (ltem)

e E

exit (lkem)

¥ = menu

x| title_icon.xml

srandroid="http://

android:id="@+id/se
android:title
android:icon="@drawable/send"

android: id="@+id/connect™
android:title="Connect™
android:icon="@drawable/connect" /=




res\values

¥ [S8] months (String Array)
(D item
@ Iltem
(@ Item
@ Item
@ Item
(D Item
@ Item
@ Item
(D item
@ Iltem
(@ Item
» (5] days (String Array)
» [S] years (String Array)
» [S] disability (String Array)
» [S] burn (String Array)
» [5] locprov (String Array)

@O OOBEOE M A

(D A string value to use in this string array.
Add... Value* 1

Remove...

Up

guesto file xml vengono contenuti

rces=

ing-array name="months">

items1</items

<ltem=2</1tem=
item=3</1ten
1tem>4</item
item>5</item

citem=6</ite

citem>T7</1item
item>8</iten
item>9</iten

<ltem=18</1te

rdy=

Tutii




The development process > Setup

Install:
Android SDK

Android Development Tool
Android Platforms

Create Android Virtual Devices
and connect hardware services
that will be used for testing.




The development process > Development

Create Android project with you
source code, resource files, and
Android manifest file.




The development process > Debug & Test

Build and run your application
in debug mode.

Debug your application using
the Android debugging and
logging tools.

Test your application using the
Android testing and
instrumental framework.




The development process > Publishing 3 ‘ %

Configure, build and test your
application in release mode.

Distribute your application to
users.




Release application

e S

To release an application means to make available
the “.apk” file.

Applications can be released in:

Android Market

Personal website
Mail / p2p system, etec.



Release application

Before you release an application you must:

- Choose an application Icon

- Prepare the End-user License Agreement (EULA)
- Turn off logging and debugging

- Clean up your project directories

- Review and update your manifest settings

if release on Android Market

- Version you application
- Sign you application with an electronic certificate
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http://android-tutorial.com/
http://www.androidtutorials.org/
http://developer.android.com/
http://www.vogella.de/android.html

Thank youl!

For more info:

Mauil:

Web:


mailto:elton.domnori@unimore.it
http://www.agentgroup.unimore.it/

